Paketname
xpdf
Datum
2007-01-18
Advisory ID
MDKSA-2007:021
Betroffene Versionen
CS4.0 x86_64 , 2007.0 x86_64 , 2007.0 i586 , CS4.0 i586 , CS3.0 x86_64 , CS3.0 i586

Problembeschreibung

The Adobe PDF specification 1.3, as implemented by xpdf 3.0.1 patch 2,
kpdf in KDE before 3.5.5, and other products, allows remote attackers
to have an unknown impact, possibly including denial of service
(infinite loop), arbitrary code execution, or memory corruption, via a
PDF file with a (1) crafted catalog dictionary or (2) a crafted Pages
attribute that references an invalid page tree node.

The updated packages have been patched to correct this problem.

Aktualisierte Pakete

CS4.0 x86_64

 5d2343239f0e46efa4df3c81a0c14191  corporate/4.0/x86_64/xpdf-3.01-1.3.20060mlcs4.x86_64.rpm 
 0c9969ce74ae66d95ff902181f83e0e5  corporate/4.0/SRPMS/xpdf-3.01-1.3.20060mlcs4.src.rpm

2007.0 x86_64

 76e9749a053f7162c894741884c89835  2007.0/x86_64/xpdf-3.01pl2-3.1mdv2007.0.x86_64.rpm
 f20e65b356ec330fd60e095add93d04a  2007.0/x86_64/xpdf-tools-3.01pl2-3.1mdv2007.0.x86_64.rpm 
 19112d086453c2fdb928011fe6f7aa0c  2007.0/SRPMS/xpdf-3.01pl2-3.1mdv2007.0.src.rpm

2007.0 i586

 e34f95bfcc5bee00a123ee84d9e14aba  2007.0/i586/xpdf-3.01pl2-3.1mdv2007.0.i586.rpm
 9fbbb1a928599ec327501ea350b8871a  2007.0/i586/xpdf-tools-3.01pl2-3.1mdv2007.0.i586.rpm 
 19112d086453c2fdb928011fe6f7aa0c  2007.0/SRPMS/xpdf-3.01pl2-3.1mdv2007.0.src.rpm

CS4.0 i586

 9899a75731800c052d32a7e8cfceedf4  corporate/4.0/i586/xpdf-3.01-1.3.20060mlcs4.i586.rpm 
 0c9969ce74ae66d95ff902181f83e0e5  corporate/4.0/SRPMS/xpdf-3.01-1.3.20060mlcs4.src.rpm

CS3.0 x86_64

 e01a2822cf592a56d89a13b73b8fa133  corporate/3.0/x86_64/xpdf-3.00-5.9.C30mdk.x86_64.rpm 
 d4e017b43f39e1dd0e3d8367c62633d2  corporate/3.0/SRPMS/xpdf-3.00-5.9.C30mdk.src.rpm

CS3.0 i586

 39a410e5887ddda80b0a2c4541082d50  corporate/3.0/i586/xpdf-3.00-5.9.C30mdk.i586.rpm 
 d4e017b43f39e1dd0e3d8367c62633d2  corporate/3.0/SRPMS/xpdf-3.00-5.9.C30mdk.src.rpm

Referenzen