Paketname
pine
Datum
2000-11-27
Advisory ID
MDKSA-2000:073-1
Betroffene Versionen
6.1 i586 , 6.0 i586 , 7.0 i586 , 7.1 i586 , 7.2 i586

Problembeschreibung

By adding specific headers to messages, the pine mail reader could be made to exit with an error message when users attempted to manipulate mail folders containing those messages. Update: The previous announcement did not make mention of another vulnerability in pine 4.21 and previous in that it also contains a buffer overflow vulnerability which allows a remote user to execute arbitrary code on the local client by the sending of a specially-crafted email message. The overflow occurs during the periodic "new mail" checking of an open folder.

Aktualisierte Pakete

6.1 i586

 94903ad5ac00ffda41d521160d32a40b  6.1/RPMS/pine-4.30-3.3mdk.i586.rpm
b19397fda44d4b23d2824fc2245ebc53  6.1/SRPMS/pine-4.30-3.3mdk.src.rpm

6.0 i586

 6102f60e5c1847d48e713cd197476c48  6.0/RPMS/pine-4.30-3.3mdk.i586.rpm
b19397fda44d4b23d2824fc2245ebc53  6.0/SRPMS/pine-4.30-3.3mdk.src.rpm

7.0 i586

 5b902033b3fed2434903db3b92132540  7.0/RPMS/pine-4.30-3.3mdk.i586.rpm
b19397fda44d4b23d2824fc2245ebc53  7.0/SRPMS/pine-4.30-3.3mdk.src.rpm

7.1 i586

 caf4defdd635fa882b35c16b0f556683  7.1/RPMS/pine-4.30-3.2mdk.i586.rpm
95a4a83fe3c602f9fc1416eff107952c  7.1/SRPMS/pine-4.30-3.2mdk.src.rpm

7.2 i586

 4213c046974d17cbce020814636de281  7.2/RPMS/pine-4.30-3.1mdk.i586.rpm
eb24c5cc0c4878206b19c1f459831f39  7.2/SRPMS/pine-4.30-3.1mdk.src.rpm