Paketname
bash1
Datum
2000-11-28
Advisory ID
MDKSA-2000:075
Betroffene Versionen
6.1 i586 , 6.0 i586 , 7.0 i586 , 7.1 i586 , 7.2 i586

Problembeschreibung

The bash1 shell program has the same << vulnerability that tcsh has and incorrectly creates temporary files without the O_EXCL flag. This vulnerability does not exist in bash2 which uses the O_EXCL flag when creating temporary files.

Aktualisierte Pakete

6.1 i586

 fc72229f27a25d43e2ef211508e3ab4d  6.1/RPMS/bash1-1.14.7-19.1mdk.i586.rpm
ebb627bd7938dfde6557a8567c2afdc6  6.1/SRPMS/bash1-1.14.7-19.1mdk.src.rpm

6.0 i586

 8e2d74346386276fcf68e6849acc68a4  6.0/RPMS/bash1-1.14.7-19.1mdk.i586.rpm
ebb627bd7938dfde6557a8567c2afdc6  6.0/SRPMS/bash1-1.14.7-19.1mdk.src.rpm

7.0 i586

 2a111d0e36318e4a415198c4a0f2461e  7.0/RPMS/bash1-1.14.7-19.1mdk.i586.rpm
ebb627bd7938dfde6557a8567c2afdc6  7.0/SRPMS/bash1-1.14.7-19.1mdk.src.rpm

7.1 i586

 0b06af1bcb9707f2016b249d36837fb5  7.1/RPMS/bash1-1.14.7-21.1mdk.i586.rpm
89c2b53695fe3389c4b69634c4b2bbf9  7.1/SRPMS/bash1-1.14.7-21.1mdk.src.rpm

7.2 i586

 f1437127f21efc3bea9affbab164684b  7.2/RPMS/bash1-1.14.7-24.1mdk.i586.rpm
39ff29cc829e0e3922d1494f57cb9e9d  7.2/SRPMS/bash1-1.14.7-24.1mdk.src.rpm