Paketname
ypserv
Datum
2002-11-18
Advisory ID
MDKSA-2002:078
Betroffene Versionen
8.1 i586 , 8.1 i586 , 8.0 i586 , 9.0 i586 , 8.2 i586 , 8.0 i586 , 8.2 i586 , 7.2 i586

Problembeschreibung

A memory leak that could be triggered remotely was discovered in ypserv 2.5 and earlier. This could lead to a Denial of Service as repeated requests for a non-existant map will result in ypserv consuming more and more memory, and also running more slowly. If the system runs out of available memory, ypserv would also be killed.

Aktualisierte Pakete

8.1 i586

 bb0c485e824d4c6f9e6ac9ac9cb3a373  ia64/8.1/RPMS/ypserv-1.3.12-3.2mdk.ia64.rpm
5e57fc67855963ec4eef3d87a4f4ba6f  ia64/8.1/SRPMS/ypserv-1.3.12-3.2mdk.src.rpm

8.1 i586

 5ad392879587b4dee5c7b5dabeefa9c9  8.1/RPMS/ypserv-1.3.12-3.2mdk.i586.rpm
5e57fc67855963ec4eef3d87a4f4ba6f  8.1/SRPMS/ypserv-1.3.12-3.2mdk.src.rpm

8.0 i586

 2bc8207693dc4e7b8095e9ce9ab761fa  8.0/RPMS/ypserv-1.3.12-3.2mdk.i586.rpm
5e57fc67855963ec4eef3d87a4f4ba6f  8.0/SRPMS/ypserv-1.3.12-3.2mdk.src.rpm

9.0 i586

 d422a834b1869149b38bf1c8a1e8a4d6  9.0/RPMS/ypserv-2.5-1.1mdk.i586.rpm
0ae1ae479fca968b041de021a6bdde56  9.0/SRPMS/ypserv-2.5-1.1mdk.src.rpm

8.2 i586

 b4b6984c3834eabd33578dfed24a53a8  8.2/RPMS/ypserv-2.5-1.1mdk.i586.rpm
0ae1ae479fca968b041de021a6bdde56  8.2/SRPMS/ypserv-2.5-1.1mdk.src.rpm

8.0 i586

 b478eda36eda7eaddb120aa065a81e3e  ppc/8.0/RPMS/ypserv-1.3.12-3.2mdk.ppc.rpm
5e57fc67855963ec4eef3d87a4f4ba6f  ppc/8.0/SRPMS/ypserv-1.3.12-3.2mdk.src.rpm

8.2 i586

 79ee559c9fcc7fd6efe25746723ea375  ppc/8.2/RPMS/ypserv-2.5-1.1mdk.ppc.rpm
0ae1ae479fca968b041de021a6bdde56  ppc/8.2/SRPMS/ypserv-2.5-1.1mdk.src.rpm

7.2 i586

 45911e795e82a5615f5c62ccdf6d442c  7.2/RPMS/ypserv-1.3.12-3.2mdk.i586.rpm
5e57fc67855963ec4eef3d87a4f4ba6f  7.2/SRPMS/ypserv-1.3.12-3.2mdk.src.rpm

Referenzen