Paketname
openssh
Datum
2000-10-10
Advisory ID
MDKSA-2000:057
Betroffene Versionen
7.0 i586 , 7.1 i586

Problembeschreibung

A problem exists with openssh's scp program. If a user uses scp to move files from a server that has been compromised, the operation can be used to replace arbitrary files on the user's system. The problem is made more serious by setuid versions of ssh which allow overwriting any file on the local user's system. If the ssh program is not setuid or is setuid to someone other than root, the intrustion is limited to files with write access granted to the owner of the ssh program. In either case, files can be overwritten with code allowing others access to the system unexpectedly. While no fix has been provided for openssh as of yet, the versions of openssh available for Linux-Mandrake 7.0 and 7.1 were setuid root. This update removes the setuid bit from the ssh program and limits the exploitability of scp somewhat. All users of Linux-Mandrake are encouraged to upgrade to these latest openssh builds. Linux-Mandrake 7.0 users will also need to upgrade openssl in order to use the 7.0 update of openssh.

Aktualisierte Pakete

7.0 i586

 305e0198128f0ff9c1c9292ec09b4dcc  7.0/RPMS/openssh-2.1.1p3-4mdk.i586.rpm
b9926356f70c27be00d2b50c96b11bd0  7.0/RPMS/openssh-askpass-2.1.1p3-4mdk.i586.rpm
c4264c9b9ab857ddd4555c05096e4697  7.0/RPMS/openssh-clients-2.1.1p3-4mdk.i586.rpm
21f1d76dc514f6e59c6023affc80dc54  7.0/RPMS/openssh-server-2.1.1p3-4mdk.i586.rpm
a3dd007c212763d4ece19b50e013edd0  7.0/RPMS/openssl-0.9.5a-3mdk.i586.rpm
b8d23e53945a0c53525701c0ed298d01  7.0/RPMS/openssl-devel-0.9.5a-3mdk.i586.rpm
a6b82e7d0e991b0d169fa00a5aeb8774  7.0/SRPMS/openssh-2.1.1p3-4mdk.src.rpm

7.1 i586

 859074e6bea599faf97ead477a8e97fe  7.1/RPMS/openssh-2.1.1p3-4mdk.i586.rpm
5df518f2b4cb308fee7b78b127972733  7.1/RPMS/openssh-askpass-2.1.1p3-4mdk.i586.rpm
a00ae71dadecbde77ccd9b4d0d0b818a  7.1/RPMS/openssh-clients-2.1.1p3-4mdk.i586.rpm
8abf7df4ed56bcbb517ebe9b549d2df7  7.1/RPMS/openssh-server-2.1.1p3-4mdk.i586.rpm
a6b82e7d0e991b0d169fa00a5aeb8774  7.1/SRPMS/openssh-2.1.1p3-4mdk.src.rpm