Paketname
xchat
Datum
2004-04-21
Advisory ID
MDKSA-2004:036
Betroffene Versionen
9.2 i586 , 9.2 amd64 , 10.0 i586

Problembeschreibung

A remotely exploitable vulnerability was discovered in the Socks-5 proxy code in XChat. By default, socks5 traversal is disabled, and one would also need to connect to an attacker's own custom proxy server in order for this to be exploited. Successful exploitation could lead to arbitrary code execution as the user running XChat. The provided packages are patched to prevent this problem.

Aktualisierte Pakete

9.2 i586

 54bc115f40f7e54fcf4a2c4d52f5676b  9.2/RPMS/xchat-2.0.4-7.1.92mdk.i586.rpm
b4762090848984ffc768be8b0eab5296  9.2/RPMS/xchat-perl-2.0.4-7.1.92mdk.i586.rpm
372ecbb839019c91a90a206e014eab5b  9.2/RPMS/xchat-python-2.0.4-7.1.92mdk.i586.rpm
79bda0db4e637c2f8517ad380503b139  9.2/RPMS/xchat-tcl-2.0.4-7.1.92mdk.i586.rpm
4bbadb5f6c4536a353e0e726ba1be312  9.2/SRPMS/xchat-2.0.4-7.1.92mdk.src.rpm

9.2 amd64

 ec523f612ef1b6f7b8387653c40b0e5b  amd64/9.2/RPMS/xchat-2.0.4-7.1.92mdk.amd64.rpm
78a3374d55635a9f746a4c847abec7c6  amd64/9.2/RPMS/xchat-perl-2.0.4-7.1.92mdk.amd64.rpm
0960061780b52f51e560905abd24b321  amd64/9.2/RPMS/xchat-python-2.0.4-7.1.92mdk.amd64.rpm
b4985a2e3f5e8d2bc249e6b7cc1d0cd3  amd64/9.2/RPMS/xchat-tcl-2.0.4-7.1.92mdk.amd64.rpm
4bbadb5f6c4536a353e0e726ba1be312  amd64/9.2/SRPMS/xchat-2.0.4-7.1.92mdk.src.rpm

10.0 i586

 7b35c6f47155aa2a279ae725f00e1ce6  10.0/RPMS/xchat-2.0.7-6.1.100mdk.i586.rpm
5576b90985a43bf934dffdcac3b8f489  10.0/RPMS/xchat-perl-2.0.7-6.1.100mdk.i586.rpm
82530135e527cd8ac99193368a81c3fb  10.0/RPMS/xchat-python-2.0.7-6.1.100mdk.i586.rpm
0135f544782942c6db5b5394bbc897f5  10.0/RPMS/xchat-tcl-2.0.7-6.1.100mdk.i586.rpm
1f80f67e7f5d26990aea8ec5c6a09f93  10.0/SRPMS/xchat-2.0.7-6.1.100mdk.src.rpm

Referenzen