Paketname
jpgraph
Datum
2009-12-26
Advisory ID
MDVSA-2009:340
Betroffene Versionen
CS4.0 x86_64 , MES5 i586 , CS4.0 i586 , MES5 x86_64

Problembeschreibung

A vulnerability has been found and corrected in jpgraph:

Multiple cross-site scripting (XSS) vulnerabilities in the
GetURLArguments function in jpgraph.php in Aditus Consulting JpGraph
3.0.6 allow remote attackers to inject arbitrary web script or HTML
via a key to csim_in_html_ex1.php, and other unspecified vectors
(CVE-2009-4422).

This update provides a solution to this vulnerability.

Aktualisierte Pakete

CS4.0 x86_64

 3f76e924133cc4b45c107fc0aba9f9c0  corporate/4.0/x86_64/php5-jpgraph-2.1.1-1.1.20060mlcs4.noarch.rpm
 538e00b525d1513db22e91bcd9fb458d  corporate/4.0/x86_64/php5-jpgraph-doc-2.1.1-1.1.20060mlcs4.noarch.rpm 
 280532b6c7e1f5f8fa76bb1a1764837f  corporate/4.0/SRPMS/php5-jpgraph-2.1.1-1.1.20060mlcs4.src.rpm

MES5 i586

 260ce8f8cd70ec01bf9a2272bb7e1788  mes5/i586/php-jpgraph-2.3.3-1.1mdvmes5.noarch.rpm
 f74acdcc63262b3a633469699553e9b9  mes5/i586/php-jpgraph-doc-2.3.3-1.1mdvmes5.noarch.rpm 
 647f834fbc35f8bddd3d1eb949d72f9c  mes5/SRPMS/php-jpgraph-2.3.3-1.1mdvmes5.src.rpm

CS4.0 i586

 937be39b1d94431f61f94a3c5a4258d5  corporate/4.0/i586/php5-jpgraph-2.1.1-1.1.20060mlcs4.noarch.rpm
 13863f4c1328886d373594dcc7d18567  corporate/4.0/i586/php5-jpgraph-doc-2.1.1-1.1.20060mlcs4.noarch.rpm 
 280532b6c7e1f5f8fa76bb1a1764837f  corporate/4.0/SRPMS/php5-jpgraph-2.1.1-1.1.20060mlcs4.src.rpm

MES5 x86_64

 07647442d1e29a5bbadcb17f38867ccb  mes5/x86_64/php-jpgraph-2.3.3-1.1mdvmes5.noarch.rpm
 1e4275ac899c4ade8bff0dbcca48af4d  mes5/x86_64/php-jpgraph-doc-2.3.3-1.1mdvmes5.noarch.rpm 
 647f834fbc35f8bddd3d1eb949d72f9c  mes5/SRPMS/php-jpgraph-2.3.3-1.1mdvmes5.src.rpm

Referenzen