Package name
mpg123
Date
2004-09-22
Advisory ID
MDKSA-2004:100
Affected versions
9.2 amd64 , CS2.1 x86_64 , 10.0 amd64 , CS2.1 i586 , 10.0 i586 , 9.2 i586

Problem description

A vulnerability in mpg123 was discovered by Davide Del Vecchio where certain malicious mpg3/2 files would cause mpg123 to fail header checks, which could in turn allow arbitrary code to be executed with the privileges of the user running mpg123 (CAN-2004-0805). As well, an older vulnerability in mpg123, where a response from a remote HTTP server could overflow a buffer allocated on the heap, is also fixed in these packages. This vulnerability could also potentially permit the execution of arbitray code with the privileges of the user running mpg123 (CAN-2003-0865).

Updated packages

9.2 amd64

 590153b9ca949f851903d6010ced9ae8  amd64/9.2/RPMS/mpg123-0.59r-21.1.92mdk.amd64.rpm
21a4273e29d60f0e79a5092b7713301b  amd64/9.2/SRPMS/mpg123-0.59r-21.1.92mdk.src.rpm

CS2.1 x86_64

 f7279fee83461fa06a9bbcc904b0ead2  x86_64/corporate/2.1/RPMS/mpg123-0.59r-21.1.C21mdk.x86_64.rpm
cba666174f4117e7776c9baa04f8983a  x86_64/corporate/2.1/SRPMS/mpg123-0.59r-21.1.C21mdk.src.rpm

10.0 amd64

 f6e601b01a3c8b24279b3465e784829a  amd64/10.0/RPMS/mpg123-0.59r-21.1.100mdk.amd64.rpm
8661f67e88ebc2821d4c5e212236465d  amd64/10.0/SRPMS/mpg123-0.59r-21.1.100mdk.src.rpm

CS2.1 i586

 714d75b86c7a99c40f522cc45f69d136  corporate/2.1/RPMS/mpg123-0.59r-21.1.C21mdk.i586.rpm
cba666174f4117e7776c9baa04f8983a  corporate/2.1/SRPMS/mpg123-0.59r-21.1.C21mdk.src.rpm

10.0 i586

 0b5270c11943064f9c0f7374f63cdc4c  10.0/RPMS/mpg123-0.59r-21.1.100mdk.i586.rpm
8661f67e88ebc2821d4c5e212236465d  10.0/SRPMS/mpg123-0.59r-21.1.100mdk.src.rpm

9.2 i586

 afe98cf7c89affb136b7048b3f387583  9.2/RPMS/mpg123-0.59r-21.1.92mdk.i586.rpm
21a4273e29d60f0e79a5092b7713301b  9.2/SRPMS/mpg123-0.59r-21.1.92mdk.src.rpm

References