Package name
postgresql
Date
2005-10-11
Advisory ID
MDKA-2005:044
Affected versions
2006.0 i586 , 2006.0 x86_64

Problem description

A number of bugs are corrected in PostgreSQL version 8.0.4 so an update for Mandrivalinux 2006 is now available (PostgreSQL 8.0.3 was provided). Fixes include various memory leakage fixes, improved checking for partially-written WAL pages, a fix for an error that allowed "VACUUM" to remove ctid chains too soon, and other fixes. A dump/reload of the databases are not required when upgrading from the provided 8.0.3 version, but may be required if upgrading from an ealier version (ie. upgrading from Mandrivalinux LE2005).

Updated packages

2006.0 i586

 8dcc0deb81957fb5d3f054e2fadc57ca  2006.0/RPMS/libecpg5-8.0.4-0.1.20060mdk.i586.rpm
3af096ebb15e076caf7ae121fc742732  2006.0/RPMS/libecpg5-devel-8.0.4-0.1.20060mdk.i586.rpm
b259398a43a5c88b0feb5c62c6f083ee  2006.0/RPMS/libpq4-8.0.4-0.1.20060mdk.i586.rpm
cca73d00b2f1b20d0b6252e1fa86b6e9  2006.0/RPMS/libpq4-devel-8.0.4-0.1.20060mdk.i586.rpm
99e655c3f397550f5a3343e616171bf7  2006.0/RPMS/postgresql-8.0.4-0.1.20060mdk.i586.rpm
5d1bd830401ba1ea5423bd8b9717f82c  2006.0/RPMS/postgresql-contrib-8.0.4-0.1.20060mdk.i586.rpm
7d690c02ea00012743ea3ec3724ef232  2006.0/RPMS/postgresql-devel-8.0.4-0.1.20060mdk.i586.rpm
f917831d8a14400e3b5daa7809067416  2006.0/RPMS/postgresql-docs-8.0.4-0.1.20060mdk.i586.rpm
92607c508dd5bdc483d3c04bda76d943  2006.0/RPMS/postgresql-jdbc-8.0.4-0.1.20060mdk.i586.rpm
19b9709a21167c12767a875f4d3c27be  2006.0/RPMS/postgresql-pl-8.0.4-0.1.20060mdk.i586.rpm
eb6bb5013a343775cd6e75e79d756fa7  2006.0/RPMS/postgresql-plperl-8.0.4-0.1.20060mdk.i586.rpm
8fc1c5417ce8aa956f17b2535c3eb34f  2006.0/RPMS/postgresql-plpgsql-8.0.4-0.1.20060mdk.i586.rpm
681e45a1666eafc2a26394781df5a4b3  2006.0/RPMS/postgresql-plpython-8.0.4-0.1.20060mdk.i586.rpm
5a3075284c7da0a349b439a21b26c3bc  2006.0/RPMS/postgresql-pltcl-8.0.4-0.1.20060mdk.i586.rpm
8caeacdede3e00619163a8c7d78fedeb  2006.0/RPMS/postgresql-server-8.0.4-0.1.20060mdk.i586.rpm
0da7a3aebb505ca790ca01ed69a899e5  2006.0/RPMS/postgresql-test-8.0.4-0.1.20060mdk.i586.rpm
81619bad5659e369ba0b9231a68d1cf8  2006.0/SRPMS/postgresql-8.0.4-0.1.20060mdk.src.rpm

2006.0 x86_64

 fb4e37cff885781dc2b08627d312e473  x86_64/2006.0/RPMS/lib64ecpg5-8.0.4-0.1.20060mdk.x86_64.rpm
80cc51d83abb39f6ec092660483caf08  x86_64/2006.0/RPMS/lib64ecpg5-devel-8.0.4-0.1.20060mdk.x86_64.rpm
07955b00fe21fea7cb3e5bfbdf633266  x86_64/2006.0/RPMS/lib64pq4-8.0.4-0.1.20060mdk.x86_64.rpm
567a6761481adc79546d0985d3097c86  x86_64/2006.0/RPMS/lib64pq4-devel-8.0.4-0.1.20060mdk.x86_64.rpm
b26fa94dc04dcc9ad3119ec6f30a86c2  x86_64/2006.0/RPMS/postgresql-8.0.4-0.1.20060mdk.x86_64.rpm
c3affcdd1f05266ba80a4bf3deee5b65  x86_64/2006.0/RPMS/postgresql-contrib-8.0.4-0.1.20060mdk.x86_64.rpm
554a01c5b4253568e50744f2af88292b  x86_64/2006.0/RPMS/postgresql-devel-8.0.4-0.1.20060mdk.x86_64.rpm
adec9034f66cb82fc0aa79133af1d4b0  x86_64/2006.0/RPMS/postgresql-docs-8.0.4-0.1.20060mdk.x86_64.rpm
2dce5e24148d8bfd1c0f66dd36325dc7  x86_64/2006.0/RPMS/postgresql-jdbc-8.0.4-0.1.20060mdk.x86_64.rpm
4900cd85c7038c1fa96df90d3ae84fc4  x86_64/2006.0/RPMS/postgresql-pl-8.0.4-0.1.20060mdk.x86_64.rpm
00fd4f583a3932999a94d882ff344c66  x86_64/2006.0/RPMS/postgresql-plperl-8.0.4-0.1.20060mdk.x86_64.rpm
1f9836658acf90330eec355f3ea0ebd9  x86_64/2006.0/RPMS/postgresql-plpgsql-8.0.4-0.1.20060mdk.x86_64.rpm
4c513a5e244b3bc67d85a0a47fea5684  x86_64/2006.0/RPMS/postgresql-plpython-8.0.4-0.1.20060mdk.x86_64.rpm
be0e6c2aa4cd69fe6ded7118fcf1781b  x86_64/2006.0/RPMS/postgresql-pltcl-8.0.4-0.1.20060mdk.x86_64.rpm
d3ac53307fac4f25cba1032eff3a8456  x86_64/2006.0/RPMS/postgresql-server-8.0.4-0.1.20060mdk.x86_64.rpm
164d73b49107ee8b370d85c61a5b16f7  x86_64/2006.0/RPMS/postgresql-test-8.0.4-0.1.20060mdk.x86_64.rpm
81619bad5659e369ba0b9231a68d1cf8  x86_64/2006.0/SRPMS/postgresql-8.0.4-0.1.20060mdk.src.rpm