Package name
glibc
Date
2002-01-08
Advisory ID
MDKSA-2001:095-1
Affected versions
8.0 i586

Problem description

Flavio Veloso found an overflowable buffer problem in earlier versions of the glibc glob(3) implementation. It may be possible to exploit some programs that pass input to the glibc glob() function in a manner that can be modified by the user. Update: The glibc update for 8.0/PPC resulted in ldconfig segfaulting consistently. This update fixes the problems with ldconfig on PPC.

Updated packages

8.0 i586

 3d88afcd39e47ff1e0d9ac7a5e8a31b0  ppc/8.0/RPMS/glibc-2.2.2-6.5mdk.ppc.rpm
bd53b5374d91549de9ab52d3fcee9204  ppc/8.0/RPMS/glibc-devel-2.2.2-6.5mdk.ppc.rpm
aca994e63c8d92ac42a87a0be0b89724  ppc/8.0/RPMS/glibc-profile-2.2.2-6.5mdk.ppc.rpm
b18e482d6390758500d3f4794ca605d5  ppc/8.0/RPMS/ldconfig-2.2.2-6.5mdk.ppc.rpm
c2ee197567d35961e27d92a16cd93feb  ppc/8.0/RPMS/nscd-2.2.2-6.5mdk.ppc.rpm
6086c1b67207093b4281450f79e597a6  ppc/8.0/SRPMS/glibc-2.2.2-6.5mdk.src.rpm

References