Package name
irssi
Date
2003-12-18
Advisory ID
MDKSA-2003:117
Affected versions
9.2 i586 , 9.1 i586 , 9.1 i586 , 9.2 amd64

Problem description

A vulnerability in versions of irssi prior to 0.8.9 would allow a remote user to crash another user's irssi client provided that the client was on a non-x86 architecture or if the "gui print text" signal is being used by some script or plugin. The updated packages provide 0.8.9 which corrects the problem.

Updated packages

9.2 i586

 97f1183b4109ae677a4605aee151cf6c  9.2/RPMS/irssi-0.8.9-0.1.92mdk.i586.rpm
b09a1ef356db586070bf696abee5a564  9.2/RPMS/irssi-devel-0.8.9-0.1.92mdk.i586.rpm
b33bfbe2ac0e92b52bfaf05ca68dc3f0  9.2/SRPMS/irssi-0.8.9-0.1.92mdk.src.rpm

9.1 i586

 7a40107bfd7d9c9fba8e2c30ca30b4e6  ppc/9.1/RPMS/irssi-0.8.9-0.1.91mdk.ppc.rpm
87fff9fbee0ff24c87edde5e4b2ed715  ppc/9.1/RPMS/irssi-devel-0.8.9-0.1.91mdk.ppc.rpm
be7ee7f215a1605fc0c5e168a195c633  ppc/9.1/SRPMS/irssi-0.8.9-0.1.91mdk.src.rpm

9.1 i586

 ab459ceb0ca53a110745d94b901612c1  9.1/RPMS/irssi-0.8.9-0.1.91mdk.i586.rpm
9f30065ecd80da6f6e1568ffe80269c1  9.1/RPMS/irssi-devel-0.8.9-0.1.91mdk.i586.rpm
be7ee7f215a1605fc0c5e168a195c633  9.1/SRPMS/irssi-0.8.9-0.1.91mdk.src.rpm

9.2 amd64

 a0ffd9b18c4ba81f178d393151b0607d  amd64/9.2/RPMS/irssi-0.8.9-0.1.92mdk.amd64.rpm
9a147f59b58e46e516576f306545a24a  amd64/9.2/RPMS/irssi-devel-0.8.9-0.1.92mdk.amd64.rpm
b33bfbe2ac0e92b52bfaf05ca68dc3f0  amd64/9.2/SRPMS/irssi-0.8.9-0.1.92mdk.src.rpm

References