Package name
webkit
Date
2011-03-02
Advisory ID
MDVSA-2011:039
Affected versions
2010.1 i586 , 2010.1 x86_64

Problem description

Multiple cross-site scripting, denial of service and arbitrary code
execution security flaws were discovered in webkit.

Please consult the CVE web links for further information.

The updated packages have been upgraded to the latest version (1.2.7)
to correct these issues.

Updated packages

2010.1 i586

 141f3cd181b875d1bb40b67a507b6db1  2010.1/i586/libwebkitgtk1.0_2-1.2.7-0.1mdv2010.2.i586.rpm
 054886a3c645b3ce710b9b9daec1d5f9  2010.1/i586/libwebkitgtk1.0-devel-1.2.7-0.1mdv2010.2.i586.rpm
 bef556ca3f281f6ef4086292c3b658d2  2010.1/i586/webkit1.0-1.2.7-0.1mdv2010.2.i586.rpm
 a1ff7ac638646aeb64e3bbdca9bc945d  2010.1/i586/webkit1.0-webinspector-1.2.7-0.1mdv2010.2.i586.rpm
 3f40e3ebc62bad67097a9e102e0e79c2  2010.1/i586/webkit-1.2.7-0.1mdv2010.2.i586.rpm
 50875cf1bc8718cedce1a45dc509b44b  2010.1/i586/webkit-gtklauncher-1.2.7-0.1mdv2010.2.i586.rpm
 625d27780d1cc9edb935d4ac3521ae16  2010.1/i586/webkit-jsc-1.2.7-0.1mdv2010.2.i586.rpm 
 8d02c28d8f21a022130be4c49f9d27be  2010.1/SRPMS/webkit-1.2.7-0.1mdv2010.2.src.rpm

2010.1 x86_64

 5ce57cd6ab823f8084030033c7c230d7  2010.1/x86_64/lib64webkitgtk1.0_2-1.2.7-0.1mdv2010.2.x86_64.rpm
 690d8718a97af93f58de3bb2357fbe9b  2010.1/x86_64/lib64webkitgtk1.0-devel-1.2.7-0.1mdv2010.2.x86_64.rpm
 7cc1d4aa77e1901ccc92f27faf85c9ea  2010.1/x86_64/webkit1.0-1.2.7-0.1mdv2010.2.x86_64.rpm
 2b77a77159529c55f64343aba98c15d9  2010.1/x86_64/webkit1.0-webinspector-1.2.7-0.1mdv2010.2.x86_64.rpm
 475cf83c5ddd8f6809c2c73a1f5a71d1  2010.1/x86_64/webkit-1.2.7-0.1mdv2010.2.x86_64.rpm
 b0f1c76107c3d54241daa7e61bfb29a9  2010.1/x86_64/webkit-gtklauncher-1.2.7-0.1mdv2010.2.x86_64.rpm
 97deff5e94a625a79842b4c240b0b00d  2010.1/x86_64/webkit-jsc-1.2.7-0.1mdv2010.2.x86_64.rpm 
 8d02c28d8f21a022130be4c49f9d27be  2010.1/SRPMS/webkit-1.2.7-0.1mdv2010.2.src.rpm

References