Package name
dhcp
Date
2009-07-28
Advisory ID
MDVSA-2009:172
Affected versions
MES5 i586 , MES5 x86_64

Problem description

A vulnerability has been found and corrected in ISC DHCP:

ISC DHCP Server is vulnerable to a denial of service, caused by the
improper handling of DHCP requests. If the host definitions are mixed
using dhcp-client-identifier and hardware ethernet, a remote attacker
could send specially-crafted DHCP requests to cause the server to
stop responding (CVE-2009-1892).

This update provides fixes for this vulnerability.

Updated packages

MES5 i586

 61c868539b33fbf517ada0933f121611  mes5/i586/dhcp-client-3.0.7-1.4mdvmes5.i586.rpm
 cf643aa926e4467559a94737790cc4d0  mes5/i586/dhcp-common-3.0.7-1.4mdvmes5.i586.rpm
 65a6a31d3efeac3116180525a5babbdf  mes5/i586/dhcp-devel-3.0.7-1.4mdvmes5.i586.rpm
 f76f144c5f5174b0e115269255d39bd8  mes5/i586/dhcp-doc-3.0.7-1.4mdvmes5.i586.rpm
 f9fce407b247f9f34a95201f7f38e3fe  mes5/i586/dhcp-relay-3.0.7-1.4mdvmes5.i586.rpm
 cd12674e3a5be0816f668ec4c99739cd  mes5/i586/dhcp-server-3.0.7-1.4mdvmes5.i586.rpm 
 ccb45066c47b000f14e1b4102994b4a5  mes5/SRPMS/dhcp-3.0.7-1.4mdvmes5.src.rpm

MES5 x86_64

 2d31a3a5f8ad86f79fe96bc93acd3f4c  mes5/x86_64/dhcp-client-3.0.7-1.4mdvmes5.x86_64.rpm
 664c6268e0c3fd88ceee31ac9f5aa456  mes5/x86_64/dhcp-common-3.0.7-1.4mdvmes5.x86_64.rpm
 8d5572a2f12ffaea8abd99121e89af84  mes5/x86_64/dhcp-devel-3.0.7-1.4mdvmes5.x86_64.rpm
 dcb5dd97e76719fd52601146258e7dc8  mes5/x86_64/dhcp-doc-3.0.7-1.4mdvmes5.x86_64.rpm
 a9881b3f7cb3f2e96ee8bb89b70beff6  mes5/x86_64/dhcp-relay-3.0.7-1.4mdvmes5.x86_64.rpm
 3a966c4356e213300c16607f6fff45e6  mes5/x86_64/dhcp-server-3.0.7-1.4mdvmes5.x86_64.rpm 
 ccb45066c47b000f14e1b4102994b4a5  mes5/SRPMS/dhcp-3.0.7-1.4mdvmes5.src.rpm

References