Nom du paquet
phpmyadmin
Date
2011-08-14
Advisory ID
MDVSA-2011:124
Affected versions
MES5 i586 , MES5 x86_64

Problem description

Multiple vulnerabilities has been discovered and corrected in
phpmyadmin:

libraries/auth/swekey/swekey.auth.lib.php in the Swekey authentication
feature in phpMyAdmin 3.x before 3.3.10.2 and 3.4.x before 3.4.3.1
assigns values to arbitrary parameters referenced in the query string,
which allows remote attackers to modify the SESSION superglobal array
via a crafted request, related to a remote variable manipulation
vulnerability. (CVE-2011-2505).

setup/lib/ConfigGenerator.class.php in phpMyAdmin 3.x before 3.3.10.2
and 3.4.x before 3.4.3.1 does not properly restrict the presence of
comment closing delimiters, which allows remote attackers to conduct
static code injection attacks by leveraging the ability to modify
the SESSION superglobal array (CVE-2011-2506).

libraries/server_synchronize.lib.php in the Synchronize implementation
in phpMyAdmin 3.x before 3.3.10.2 and 3.4.x before 3.4.3.1 does not
properly quote regular expressions, which allows remote authenticated
users to inject a PCRE e (aka PREG_REPLACE_EVAL) modifier, and
consequently execute arbitrary PHP code, by leveraging the ability
to modify the SESSION superglobal array (CVE-2011-2507).

Directory traversal vulnerability in libraries/display_tbl.lib.php
in phpMyAdmin 3.x before 3.3.10.2 and 3.4.x before 3.4.3.1, when
a certain MIME transformation feature is enabled, allows remote
authenticated users to include and execute arbitrary local files
via a .. (dot dot) in a GLOBALS[mime_map][->name][transformation]
parameter (CVE-2011-2508).

Multiple cross-site scripting (XSS) vulnerabilities in the table Print
view implementation in tbl_printview.php in phpMyAdmin before 3.3.10.3
and 3.4.x before 3.4.3.2 allow remote authenticated users to inject
arbitrary web script or HTML via a crafted table name (CVE-2011-2642).

Directory traversal vulnerability in sql.php in phpMyAdmin 3.4.x before
3.4.3.2, when configuration storage is enabled, allows remote attackers
to include and execute arbitrary local files via directory traversal
sequences in a MIME-type transformation parameter (CVE-2011-2643).

Multiple directory traversal vulnerabilities in the relational
schema implementation in phpMyAdmin 3.4.x before 3.4.3.2 allow remote
authenticated users to include and execute arbitrary local files via
directory traversal sequences in an export type field, related to
(1) libraries/schema/User_Schema.class.php and (2) schema_export.php
(CVE-2011-2718).

libraries/auth/swekey/swekey.auth.lib.php in phpMyAdmin 3.x before
3.3.10.3 and 3.4.x before 3.4.3.2 does not properly manage sessions
associated with Swekey authentication, which allows remote attackers
to modify the SESSION superglobal array, other superglobal arrays,
and certain swekey.auth.lib.php local variables via a crafted query
string, a related issue to CVE-2011-2505 (CVE-2011-2719).

The updated packages have been upgraded to the 3.4.3.2 version which
is not vulnerable to these issues.

Updated packages

MES5 i586

 cd0464c4da204a8a252ccb8424318aec  mes5/i586/phpmyadmin-3.4.3.2-0.1mdvmes5.2.noarch.rpm 
 60861f8222ce497b5a71b7a6b37f4b47  mes5/SRPMS/phpmyadmin-3.4.3.2-0.1mdvmes5.2.src.rpm

MES5 x86_64

 9f1d82952b71b146189b98f6ae03cbce  mes5/x86_64/phpmyadmin-3.4.3.2-0.1mdvmes5.2.noarch.rpm 
 60861f8222ce497b5a71b7a6b37f4b47  mes5/SRPMS/phpmyadmin-3.4.3.2-0.1mdvmes5.2.src.rpm

References