Nome do pacote
openslp
Data
2012-08-21
ID Alerta
MDVSA-2012:141
Versões afetadas
MES5 i586 , 2011 i586 , MES5 x86_64 , 2011 x86_64

Descrição do problema

A vulnerability has been discovered and corrected in openslp:

The extension parser in slp_v2message.c in OpenSLP 1.2.1 allows
remote attackers to cause a denial of service (infinite loop) via a
packet with a next extension offset that references this extension
or a previous extension (CVE-2010-3609).

The updated packages have been patched to correct this issue.

Pacotes atualizados

MES5 i586

 a40037a13c38b45d5039be5d22f2433e  mes5/i586/libopenslp1-1.2.1-12.1mdvmes5.2.i586.rpm
 a1729c8647bf70e77e8d364a29f617fd  mes5/i586/libopenslp1-devel-1.2.1-12.1mdvmes5.2.i586.rpm
 a8aa5df5e5a2dcd657fb829a6c8a0487  mes5/i586/openslp-1.2.1-12.1mdvmes5.2.i586.rpm 
 ef941a2127557eb31d6a7629a75301d4  mes5/SRPMS/openslp-1.2.1-12.1mdvmes5.2.src.rpm

2011 i586

 603e96d0183123980fa0c958cb0d0df8  2011/i586/libopenslp1-1.2.1-12.1-mdv2011.0.i586.rpm
 3092ff906d7d14dd9b7df405d35ac62f  2011/i586/libopenslp1-devel-1.2.1-12.1-mdv2011.0.i586.rpm
 922481da01e2643b57bd51eef10f8a9a  2011/i586/openslp-1.2.1-12.1-mdv2011.0.i586.rpm 
 2b476b51b52217d48b6aab0424d61034  2011/SRPMS/openslp-1.2.1-12.1.src.rpm

MES5 x86_64

 36e119c7d9ea425ca63a9a76071ee634  mes5/x86_64/lib64openslp1-1.2.1-12.1mdvmes5.2.x86_64.rpm
 be446fa9a2874f48e9de20938dce667e  mes5/x86_64/lib64openslp1-devel-1.2.1-12.1mdvmes5.2.x86_64.rpm
 041d302cd2a3b1302ec764bab9c05191  mes5/x86_64/openslp-1.2.1-12.1mdvmes5.2.x86_64.rpm 
 ef941a2127557eb31d6a7629a75301d4  mes5/SRPMS/openslp-1.2.1-12.1mdvmes5.2.src.rpm

2011 x86_64

 94671946b214ea282a2d4b0c224263c9  2011/x86_64/lib64openslp1-1.2.1-12.1-mdv2011.0.x86_64.rpm
 10655e477ea1508b4784f0660f7d1acd  2011/x86_64/lib64openslp1-devel-1.2.1-12.1-mdv2011.0.x86_64.rpm
 1e35c2323231d3a211f8cc33f3decf6a  2011/x86_64/openslp-1.2.1-12.1-mdv2011.0.x86_64.rpm 
 2b476b51b52217d48b6aab0424d61034  2011/SRPMS/openslp-1.2.1-12.1.src.rpm

Referências