Package name
gpdf
Date
2005-02-17
Advisory ID
MDKSA-2005:042
Affected versions
10.0 amd64 , CS3.0 x86_64 , 10.1 x86_64

Problem description

Previous updates to correct integer overflow issues affecting xpdf overlooked certain conditions when built for a 64 bit platform. (formerly CAN-2004-0888). This also affects applications like gpdf, that use embedded versions of xpdf. The updated packages are patched to deal with these issues.

Updated packages

10.0 amd64

 d06514c07d91079c76b120d1331d479a  amd64/10.0/RPMS/gpdf-0.112-2.6.100mdk.amd64.rpm
e89f8e696edbe10cd00741acca0a75c7  amd64/10.0/SRPMS/gpdf-0.112-2.6.100mdk.src.rpm

CS3.0 x86_64

 6e385cc821332dde1b9c216424eadbbe  x86_64/corporate/3.0/RPMS/gpdf-0.112-2.6.C30mdk.x86_64.rpm
44600333f205ef33c9250302fc277c1b  x86_64/corporate/3.0/SRPMS/gpdf-0.112-2.6.C30mdk.src.rpm

10.1 x86_64

 4e492af8918055d5d636de1bc32fa982  x86_64/10.1/RPMS/gpdf-0.132-3.5.101mdk.x86_64.rpm
bd941e699cb9694b94ebae550a462684  x86_64/10.1/SRPMS/gpdf-0.132-3.5.101mdk.src.rpm

References