Nom du paquet
xsupplicant
Date
2006-10-27
Advisory ID
MDKSA-2006:189
Affected versions
2006.0 i586 , 2006.0 x86_64 , 2007.0 x86_64 , 2007.0 i586

Problem description

Yannick Van Osselaer discovered a stack overflow in Xsupplicant, which
could potentially be exploited by a remote, authenticated user to gain
root priviledges. Additional code cleanups to fix potential memory
leaks are also included.

Updated packages have been patched to correct this issue.

Updated packages

2006.0 i586

 d35f3cee0c66c5778acd39a64e46704a  2006.0/i586/xsupplicant-1.0.1-3.1.20060mdk.i586.rpm
 3df3a3e96b0be68eda96dcffd557a014  2006.0/i586/xsupplicant-doc-1.0.1-3.1.20060mdk.i586.rpm 
 3685820c2527d4608a2fc1722eba6b63  2006.0/SRPMS/xsupplicant-1.0.1-3.1.20060mdk.src.rpm

2006.0 x86_64

 d2e450ac1c2f4dac7968a08a8cb2f2c4  2006.0/x86_64/xsupplicant-1.0.1-3.1.20060mdk.x86_64.rpm
 6027f2b00d4d2c966bcacbdd38a6895b  2006.0/x86_64/xsupplicant-doc-1.0.1-3.1.20060mdk.x86_64.rpm 
 3685820c2527d4608a2fc1722eba6b63  2006.0/SRPMS/xsupplicant-1.0.1-3.1.20060mdk.src.rpm

2007.0 x86_64

 46878703a426d4d5770c1572c397f54c  2007.0/x86_64/xsupplicant-1.2.6-1.1mdv2007.0.x86_64.rpm
 bdc5f953605ab0404eb1075e0cb42ac6  2007.0/x86_64/xsupplicant-devel-1.2.6-1.1mdv2007.0.x86_64.rpm
 3023ec5a0ee41f083c6372add22e8444  2007.0/x86_64/xsupplicant-doc-1.2.6-1.1mdv2007.0.x86_64.rpm 
 b126177e58162c5bbeddda641d874423  2007.0/SRPMS/xsupplicant-1.2.6-1.1mdv2007.0.src.rpm

2007.0 i586

 b122033612442db1eaf3795e74947a25  2007.0/i586/xsupplicant-1.2.6-1.1mdv2007.0.i586.rpm
 5919e8bb474dea74a5b0e80746d3821c  2007.0/i586/xsupplicant-devel-1.2.6-1.1mdv2007.0.i586.rpm
 2e890e6b58ab87e6104bbd2cbcfac297  2007.0/i586/xsupplicant-doc-1.2.6-1.1mdv2007.0.i586.rpm 
 b126177e58162c5bbeddda641d874423  2007.0/SRPMS/xsupplicant-1.2.6-1.1mdv2007.0.src.rpm

References