Nom du paquet
wordnet
Date
2008-09-15
Advisory ID
MDVSA-2008:182-1
Affected versions
2008.1 i586 , 2008.1 x86_64 , 2008.0 i586 , 2008.0 x86_64

Problem description

Rob Holland found several programming errors in WordNet which could
lead to the execution or arbitrary code when used with untrusted input
(CVE-2008-2149, CVE-2008-3908).

Update:

The previous patch had a typo that caused incorrect behaviour in
WordNet. This update uses an update patch that corrects the issue
and also notes the additional assigned CVE name for these issues.

Updated packages

2008.1 i586

 fdbb49dbd64ed7635088b9ee613e5786  2008.1/i586/libwordnet3.0-3.0-6.2mdv2008.1.i586.rpm
 361e9bb12cdf618a12fcd7df41a98690  2008.1/i586/libwordnet3.0-devel-3.0-6.2mdv2008.1.i586.rpm
 e1888e6cbad6140e67932764a479fee7  2008.1/i586/wordnet-3.0-6.2mdv2008.1.i586.rpm 
 ed24b17d2cfc64cdc814de1114a94f4b  2008.1/SRPMS/wordnet-3.0-6.2mdv2008.1.src.rpm

2008.1 x86_64

 26ca8beb8ffa8a778e290248221fe204  2008.1/x86_64/lib64wordnet3.0-3.0-6.2mdv2008.1.x86_64.rpm
 5bc62faa924d2b633249ed486e3396df  2008.1/x86_64/lib64wordnet3.0-devel-3.0-6.2mdv2008.1.x86_64.rpm
 ba9444c750762049a65de3c3dd5732af  2008.1/x86_64/wordnet-3.0-6.2mdv2008.1.x86_64.rpm 
 ed24b17d2cfc64cdc814de1114a94f4b  2008.1/SRPMS/wordnet-3.0-6.2mdv2008.1.src.rpm

2008.0 i586

 1d0d82775493396e34971c884cbabc01  2008.0/i586/libwordnet3.0-3.0-6.2mdv2008.0.i586.rpm
 eceaba3f5a49a9006bc415e778651bf2  2008.0/i586/libwordnet3.0-devel-3.0-6.2mdv2008.0.i586.rpm
 96fb48c0c5a8b91884294f93bbe47399  2008.0/i586/wordnet-3.0-6.2mdv2008.0.i586.rpm 
 494942f67dad01f8223f20ec9a255cff  2008.0/SRPMS/wordnet-3.0-6.2mdv2008.0.src.rpm

2008.0 x86_64

 45a324ee32d6fa613a862b4d905f4738  2008.0/x86_64/lib64wordnet3.0-3.0-6.2mdv2008.0.x86_64.rpm
 e220080ca764c251d274f7ced28ea5fb  2008.0/x86_64/lib64wordnet3.0-devel-3.0-6.2mdv2008.0.x86_64.rpm
 149fb69b656abf7360b750882931de41  2008.0/x86_64/wordnet-3.0-6.2mdv2008.0.x86_64.rpm 
 494942f67dad01f8223f20ec9a255cff  2008.0/SRPMS/wordnet-3.0-6.2mdv2008.0.src.rpm

References