Nom du paquet
kde3
Date
2003-04-24
Advisory ID
MDKSA-2003:049-1
Affected versions
9.1 i586

Problem description

A vulnerability was discovered by the KDE team in the way that KDE uses Ghostscript for processing PostScript and PDF files. A malicious attacker could provide a carefully constructed PDF or PostScript file to an end user (via web or mail) that could lead to the execution of arbitrary commands as the user viewing the file. The vulnerability can be triggered even by the browser generating a directory listing with thumbnails. All users are encouraged to upgrade to these new kdegraphics, kdebase, and kdelibs packages that contain patches to correct the problem. This issue is corrected upstream in KDE 3.0.5b and KDE 3.1.1a. Update: The previous update was missing a fix in kdebase specific to HP machines. This has been corrected.

Updated packages

9.1 i586

 51635c23eef874e2379e60609125035c  9.1/RPMS/kdebase-3.1-83.3mdk.i586.rpm
c96b3cd85f844f5627ab90f79f9e855f  9.1/RPMS/kdebase-devel-3.1-83.3mdk.i586.rpm
5f1acb64918640c3a82da41ab973f102  9.1/RPMS/kdebase-kdm-3.1-83.3mdk.i586.rpm
96177d2fb0018e1562e73e9d9bd1dcac  9.1/RPMS/kdebase-nsplugins-3.1-83.3mdk.i586.rpm
932b1ac750587c229e3ea0286bbd0147  9.1/SRPMS/kdebase-3.1-83.3mdk.src.rpm

References