Nom du paquet
gedit
Date
2005-06-15
Advisory ID
MDKSA-2005:102
Affected versions
10.2 x86_64 , 10.2 i586 , 10.1 i586 , CS3.0 x86_64 , CS3.0 i586 , 10.1 x86_64

Problem description

A vulnerability was discovered in gEdit where it was possible for an attacker to create a file with a carefully crafted name which, when opened, executed arbitrary code on the victim's computer. It is highly unlikely that a user would open such a file, due to the file name, but could possibly be tricked into opening it. The updated packages have been patched to correct this problem.

Updated packages

10.2 x86_64

 e9127869bb04e5bebe7672467124356e  x86_64/10.2/RPMS/gedit-2.8.3-1.1.102mdk.x86_64.rpm
806df1df2ac01c0e72743f4932d75b24  x86_64/10.2/RPMS/gedit-devel-2.8.3-1.1.102mdk.x86_64.rpm
7287a31def37df199fa9b38ef8a82b84  x86_64/10.2/SRPMS/gedit-2.8.3-1.1.102mdk.src.rpm

10.2 i586

 d3d93eb0f5ab7ad289ea57f113c1f366  10.2/RPMS/gedit-2.8.3-1.1.102mdk.i586.rpm
f5667873ab54a1c018a336e35c4acea0  10.2/RPMS/gedit-devel-2.8.3-1.1.102mdk.i586.rpm
7287a31def37df199fa9b38ef8a82b84  10.2/SRPMS/gedit-2.8.3-1.1.102mdk.src.rpm

10.1 i586

 8241da598913e20edca0f815160fe70c  10.1/RPMS/gedit-2.6.2-4.2.101mdk.i586.rpm
f6fad63fb7bf53827336dd5472bd1504  10.1/RPMS/gedit-devel-2.6.2-4.2.101mdk.i586.rpm
bc70d881c5b384cbf49cf8b7c8867956  10.1/SRPMS/gedit-2.6.2-4.2.101mdk.src.rpm

CS3.0 x86_64

 94f5f006e378ac24d6e11fb149c4bf1f  x86_64/corporate/3.0/RPMS/gedit-2.4.1-7.2.C30mdk.x86_64.rpm
291d0f1b6c1f7dbc3b7720d06e1a1f5b  x86_64/corporate/3.0/SRPMS/gedit-2.4.1-7.2.C30mdk.src.rpm

CS3.0 i586

 1f55902f5f5a3ae4f7e92f45363b0d2a  corporate/3.0/RPMS/gedit-2.4.1-7.2.C30mdk.i586.rpm
291d0f1b6c1f7dbc3b7720d06e1a1f5b  corporate/3.0/SRPMS/gedit-2.4.1-7.2.C30mdk.src.rpm

10.1 x86_64

 448a7e77de4af2882d5ce39eae4a3ee2  x86_64/10.1/RPMS/gedit-2.6.2-4.2.101mdk.x86_64.rpm
16d8483b53c677cfea541791eaaaa34c  x86_64/10.1/RPMS/gedit-devel-2.6.2-4.2.101mdk.x86_64.rpm
bc70d881c5b384cbf49cf8b7c8867956  x86_64/10.1/SRPMS/gedit-2.6.2-4.2.101mdk.src.rpm

References